1. Ask questions. Share your HPI Savage knowledge. Register TODAY!

Welcome to HPISavageForum, a friendly forum to discuss the Savage RC Truck.

Your voice is missing! You will need to register to get access to the following site features:
  • Reply to discussions and create your own threads.
  • Our modern chat room. No add-ons or extensions required, just login and start chatting.
  • Access to private conversations with other members.

We hope to see you as a part of our community soon!

New Savage x 4.6 slipping & shifting problems?

Discussion in 'HPI Savage' started by bplawlor, May 14, 2017.

Tags:
  1. bplawlor

    bplawlor New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    May 14, 2017
    Hey guys, I just purchased a savage x 4.6. I broke it in and the first tank after break in I was driving it on grass and I noticed it was slipping & revving really high with no power. I could smell burning plastic. So I stopped & took the spur gear off and it was pretty worn out. It seems like HPI didnt tighten the nut enough. So I re tightened it and went back out. It seems to be doing better, but still slipping I think at high speeds. Could the clutch shoes be worn only after a few tanks of fuel? Also I cant get the trick to shift at all. I have loosened the correct screw and still nothing. It seems like it doesn't have much power, so maybe I am starting off in second gear.
    I will calla HPI tomorrow since the truck is pretty much brand new. I will be ordering the alum clutch shoes & a new spur gear with the pads. Any input is appreciated.
     
  2. ElocFSU

    ElocFSU Member

    Messages:
    9
    Likes Received:
    0
    Joined:
    May 5, 2017
    Location:
    Houston, TX
    Hey there,

    I'm new myself so I'll leave answering your questions to the experts. Just wanted to say hi and let you know that I also just purchased a new Savage X 4.6 and am currently working through break-in. You are ahead of me - I'm currently three tanks into the process so I'm still running super rich at half throttle max for now. I'd like to share some notes with you and see if you experienced similar. If you get a chance, look up a thread called "Requesting Break-In Advice" and let me know your thoughts.
     
  3. bplawlor

    bplawlor New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    May 14, 2017
    UPDATE:
    I just went out with it, & noticed that HPI had the second gear out 8-10 full turns out, so it was staring out in second gear. I adjusted it 5 turns out and seems pretty good. I tightened the spur gear as tight as i could & everything seems to be working okay

    Thanks you
     
  4. bplawlor

    bplawlor New Member

    Messages:
    3
    Likes Received:
    0
    Joined:
    May 14, 2017
    After breaking it in, I recommend you checking the spur gear tightness as well as the second gear screw. I believe HPI made a mistake on mine from the factory, Thank you for the response!
     
Verification:
Draft saved Draft deleted
Loading...

Share This Page