1. Ask questions. Share your HPI Savage knowledge. Register TODAY!

Welcome to HPISavageForum, a friendly forum to discuss the Savage RC Truck.

Your voice is missing! You will need to register to get access to the following site features:
  • Reply to discussions and create your own threads.
  • Our modern chat room. No add-ons or extensions required, just login and start chatting.
  • Access to private conversations with other members.

We hope to see you as a part of our community soon!

E savage esc problem

Discussion in 'Electric Motors and ESC' started by Antndrew78, Jul 15, 2018.

  1. Antndrew78

    Antndrew78 Member

    Joined:
    Dec 29, 2017
    Messages:
    22
    Likes Received:
    0
    I picked up an e savage for a good deal it came with the hpi batteries that surprisingly still take a good charge the problem I am having is when you pull the throttle it won’t go but if you pull the trigger very very lightly reward like a mil meter back it will start to work then you can pull the throttle and it will start to throttle up to full power but that would be very hard to drive this way I swapped the recieve out with a flysky and still did the same thing can’t figure this out any help would be great
     
  2. Jam Racing 1

    Jam Racing 1 NPTB Monitor, Master of the known universe....
    HPISF Staff

    Joined:
    Jun 20, 2008
    Messages:
    4,389
    Likes Received:
    629
    try recalibrating the esc and see if that helps.....
     
  3. Antndrew78

    Antndrew78 Member

    Joined:
    Dec 29, 2017
    Messages:
    22
    Likes Received:
    0
    That’s the problem I can’t figure out how
     
  4. Jam Racing 1

    Jam Racing 1 NPTB Monitor, Master of the known universe....
    HPISF Staff

    Joined:
    Jun 20, 2008
    Messages:
    4,389
    Likes Received:
    629
    well maybe a pic of it and if possible the model number......
     
  5. Jam Racing 1

    Jam Racing 1 NPTB Monitor, Master of the known universe....
    HPISF Staff

    Joined:
    Jun 20, 2008
    Messages:
    4,389
    Likes Received:
    629
  6. Antndrew78

    Antndrew78 Member

    Joined:
    Dec 29, 2017
    Messages:
    22
    Likes Received:
    0
    4F521484-0C1D-4E82-80FC-9AB7039A643E.jpeg 72BDAB51-9EB8-482A-97CE-EF3450D51FF9.jpeg 72BDAB51-9EB8-482A-97CE-EF3450D51FF9.jpeg
     

    Attached Files:

  7. Antndrew78

    Antndrew78 Member

    Joined:
    Dec 29, 2017
    Messages:
    22
    Likes Received:
    0
    I also have the Manual but All it pretty much states is how to check the esc am i missing something it does say set up but I can’t find it in the manual
     
  8. Jam Racing 1

    Jam Racing 1 NPTB Monitor, Master of the known universe....
    HPISF Staff

    Joined:
    Jun 20, 2008
    Messages:
    4,389
    Likes Received:
    629
    Looks like it is an automatic setup type unit, unplug the batteries, unplug the esc from the receiver and set all the radio settings to neutral, and then plug everything back in and see if it sets up according to the manual.....

    Also be aware since that kit is discontinued it will be difficult to get parts for should you break something......
     
  9. Antndrew78

    Antndrew78 Member

    Joined:
    Dec 29, 2017
    Messages:
    22
    Likes Received:
    0
    If the esc is broken I am going to go brushless something mild since the factory esc cost a lot more then I paid for it
     
    • Optimistic Optimistic x 1
  10. Antndrew78

    Antndrew78 Member

    Joined:
    Dec 29, 2017
    Messages:
    22
    Likes Received:
    0
    Does the manual state that order because I couldn’t find anything
     
  11. Jam Racing 1

    Jam Racing 1 NPTB Monitor, Master of the known universe....
    HPISF Staff

    Joined:
    Jun 20, 2008
    Messages:
    4,389
    Likes Received:
    629
    No but simple deduction tells me if you remove the power source and unplug the unit it will allow you to reset it......
     
  12. Antndrew78

    Antndrew78 Member

    Joined:
    Dec 29, 2017
    Messages:
    22
    Likes Received:
    0
    Tried it and still the same going to try another set of batteries I just ordered the adaptors so some time next week thanks for the help so far
     
  13. olds97_lss

    olds97_lss Well-Known Member

    Joined:
    Oct 2, 2015
    Messages:
    1,562
    Likes Received:
    262
    Location:
    Dekalb, IL 60115
    What batteries are you using? NiMH or LiPo? Did you charge them even though they had charge in them? Batteries can read a lot higher voltage until you apply load. Then the voltage drops. I don't notice that so much with LiPo, but with NiMH packs, especially older ones, they do that.
     
  14. Antndrew78

    Antndrew78 Member

    Joined:
    Dec 29, 2017
    Messages:
    22
    Likes Received:
    0
    Ok got the adaptors to try a different set and combo of batteries and it worked I ran the truck about 10 min and it was fine I recharged the batteries to run it again and it’s back to the same problem will try and see if I can get this video up here is the link to the video
     
  15. Antndrew78

    Antndrew78 Member

    Joined:
    Dec 29, 2017
    Messages:
    22
    Likes Received:
    0
    Update I disconnected one motor and it’s working.I then switched and tried the other motor and it ran normal hooked them both up and it ran normal so I am very stumped unless all my batteries are starting to go once I had it running it ran the batteries down quick
     
    #15 Antndrew78, Jul 20, 2018
    Last edited: Jul 21, 2018
  16. savagenew

    savagenew New Member

    Joined:
    Aug 9, 2018
    Messages:
    2
    Likes Received:
    0
    I am having a very similar issue to this
     

Share This Page