1. Ask questions. Share your HPI Savage knowledge. Register TODAY!

Welcome to HPISavageForum, a friendly forum to discuss the Savage RC Truck.

Your voice is missing! You will need to register to get access to the following site features:
  • Reply to discussions and create your own threads.
  • Our modern chat room. No add-ons or extensions required, just login and start chatting.
  • Access to private conversations with other members.

We hope to see you as a part of our community soon!

Vapor pro esc broken

Discussion in 'Electric Motors and ESC' started by orzowei69, Oct 30, 2017.

Tags:
  1. orzowei69

    orzowei69 Member

    Messages:
    10
    Likes Received:
    4
    Joined:
    Mar 14, 2017
    Location:
    Spain
    Today I discovered that my second vapor pro esc has also failed.
    The first one (came with the savage xs) smoked due to bad thermal contact between the mosfets and the heatsink. There was over half milimeter of resin in between.
    The second one has just stopped working. Leds blink correctly when indicating forward reverse and neutral but the motor does not move. Motor is ok.
    I am not getting another of these castle rebranded escs. Too much fame but they are not worth the money. Just wanted to post my experience with this esc type.
     
  2. WoodiE

    WoodiE Kind of good admin HPISF Staff

    Messages:
    1,347
    Likes Received:
    161
    Joined:
    Mar 14, 2014
    Location:
    Kentucky
    Thanks for sharing @orzowei69. Looks like another case of "you get what you pay for".
     
Verification:
Draft saved Draft deleted

Share This Page