Steering Problem

baris41

Member
Messages
28
Hey guys,

After my transmission problem i reassemble everything. This time car does not steer.:cautious: First i thought that the servo is dead, but i can steer it with trim button. So would you help to identify my problem? Might that be an esc or receiver problem?

 

orzowei69

Active Member
Messages
97
Location
Spain
Hey guys,

After my transmission problem i reassemble everything. This time car does not steer.:cautious: First i thought that the servo is dead, but i can steer it with trim button. So would you help to identify my problem? Might that be an esc or receiver problem?

Hi. Make sure that the servo cable is connected to channel #1 output of the receiver. Maybe the trim button that seems to work is for another channel different to #1.
 

baris41

Member
Messages
28
Hi. Make sure that the servo cable is connected to channel #1 output of the receiver. Maybe the trim button that seems to work is for another channel different to #1.

It was on the #1 channel, it looks fuzzy on the video. You can see throttle works as it it should be at the end of the video. Any other suggestions?
 

orzowei69

Active Member
Messages
97
Location
Spain
It was on the #1 channel, it looks fuzzy on the video. You can see throttle works as it it should be at the end of the video. Any other suggestions?
Hi. Since steering was working before you disassembled the car It is not probable that servo, receiver or transmitter are broken. I would focus on checking electrical connections, transmitter settings and mechanical assembly.
Check that the servo connector polarity is correct in the receiver socket.
Besides the trimmer for steering centering, there is another trimmer for the steering "length". Make sure it is not set at 0.
Next thing I would do is disconnect the servo arm or try with another servo, to see if the servo can fully move without load (some steering parts can be stuck if they are not properly assembled).
You can find cheap servo testers which are very useful for this situations.
 

baris41

Member
Messages
28
After a long research, i found out that the controller wheel pin came loose out of the electric board :) odd problem, fixed it. Thanks again!
 

Latest posts

Members online

No members online now.
Top