1. Ask questions. Share your HPI Savage knowledge. Register TODAY!

Welcome to HPISavageForum, a friendly forum to discuss the Savage RC Truck.

Your voice is missing! You will need to register to get access to the following site features:
  • Reply to discussions and create your own threads.
  • Our modern chat room. No add-ons or extensions required, just login and start chatting.
  • Access to private conversations with other members.

We hope to see you as a part of our community soon!

Savage Octane problems

Discussion in 'HPI Savage Octane' started by arod3000s, Jun 13, 2018.

  1. arod3000s

    arod3000s Member

    Joined:
    Jun 13, 2018
    Messages:
    7
    Likes Received:
    0
    having problems starting the engine , carbs has been clean, new filter spark plug batteries ect... it start then stall after 2mins , have check the ls and hs but nothing, motor pretty clean and in good conditions , main issue is that it start and stall after 2 mins basically it wont run.. not even my nitros or bajas have gave me so much pain. i really want it to start and enjoyed ( am the 2nd owner , it was a buddy of mines and it was well keep just like the other rc we got, the truck has 5 tanks ran on it. ) i have read the forums and alot of them are carb settings issue , i haven't try the 2s LiPo for the ignition instead of the 6v battery might try it today but kinda know thats not the problem here. it got to be something in the carb not letting gas flow thru after it start up,HELP ME OUT HERE PLS AND ON THE FUTURE I WILL HELP YOU HEHE... i don't know if it still needs the break in process, the Octane its pretty new to me but my knowledge on other rc its pretty big its not like i started few day ago and once you know it is simple but we all learn every day more about the hobby.. so lets see what you guys can help me with I'm open to any info...
     
  2. olds97_lss

    olds97_lss Well-Known Member

    Joined:
    Oct 2, 2015
    Messages:
    1,434
    Likes Received:
    236
    Location:
    Dekalb, IL 60115
    Could be the ignition box is dying and once it's been running a bit, it heats up and fails.
     
  3. Savage 6768

    Savage 6768 Member

    Joined:
    Mar 28, 2018
    Messages:
    41
    Likes Received:
    3
    Location:
    New Zealand
    There is a post here on this forum were the guy changed the carb with good results
     
  4. arod3000s

    arod3000s Member

    Joined:
    Jun 13, 2018
    Messages:
    7
    Likes Received:
    0
    The ignition box got swap or a new one just in case but still the same problem, so far it we stall bcz it dry no gas on it so it has to be carb problems
     
  5. arod3000s

    arod3000s Member

    Joined:
    Jun 13, 2018
    Messages:
    7
    Likes Received:
    0
    yeah i have read a few of them with carb problems and with a new carbs everything goes back to normal... the bad thing is that the carb is out of stock for a new one not even DDM have them on stock so i might have to wait or put a slight bigger carb which is better more gas flow... but yeah I'm still stuck
     

Share This Page