K4.6 half tank lean buggin me man, what to do????

Thread starter #1
Messages
27
Likes
0
Location
jeffrey west virginia
hey all, So lately I built this savage 25 with a new k4.6 I had stashed back, it runs good to about half a tank, then she goes lean, I know theres a fix for this, running new fuel lines, I tried that, just wondered if anyone has ran into this problem before and how they fixed it? any help or ideas would be appreciated!! Kdogg
 

olds97_lss

Well-Known Member
Messages
1,624
Likes
274
Location
Dekalb, IL 60115
There's probably quite a few threads on it. Many change to a more uniform tank by either running a smaller buggy tank in the stock location or doing the mid-tank mod and moving the receiver/battery/tb servo.

I run a smaller tank in the stock location. Since I have 4 shocks, I have room on the back of my X. With an 8 shock setup, you can still do it, but it puts the tank down below the engine and doesn't work as well. It's best to have the tank as even with the carb as you can.

As you can see below this thread, there are 5 similar threads listed, but guessing there's many many more. Not sure what you see, but this is what I see:


I think this was the last thread I posted my stuff in, which is the first on that list below:
https://www.hpisavageforum.com/threads/half-tank-lean.18789/
 
Thread starter #3
Messages
27
Likes
0
Location
jeffrey west virginia
Hey. I read your post after I posted on here, I will try a ofna tank, I have a new set of big bores laying around if I need to use them, glad I saw your post mr olds. many thanks!
 
Top