1. Ask questions. Share your HPI Savage knowledge. Register TODAY!

Welcome to HPISavageForum, a friendly forum to discuss the Savage RC Truck.

Your voice is missing! You will need to register to get access to the following site features:
  • Reply to discussions and create your own threads.
  • Our modern chat room. No add-ons or extensions required, just login and start chatting.
  • Access to private conversations with other members.

We hope to see you as a part of our community soon!

Help please!! Noobie

Discussion in 'Chassis & Drivetrain' started by Plkih, Jan 15, 2017.

Tags:
  1. Plkih

    Plkih New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Jan 15, 2017
    I purchased a HPI Bullet 3.0 Stadium truck yesterday.

    I was completing the second run through of fuel when I started the engine, it went a full speed (of the ground) then the engine cut off, now I can't pull on the cord anymore what could of happened?

    I removed the Glow plug but this didn't do anything.
    I removed the Pull Start Assy and this freely moves freely

    Any suggests would be great

    Complete noobie here.
     
    Last edited: Jan 15, 2017
  2. Conv3rted

    Conv3rted Member

    Messages:
    17
    Likes Received:
    0
    Joined:
    Jan 12, 2017
    I haven't been in nitro for a while but i would suspect crank/rod failure or clutch/outdrive locked up. Did you break in the engine properly? Seems that took a few tanks of fuel itself. Just my 2 cents bud.
     
  3. Plkih

    Plkih New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Jan 15, 2017

    thanks for your help. Would it fail straight out the box? I only got it yesterday. Put a full tank of fuel through, with the wheels of the ground like it said it the manual, and was in the process of completing the second tank through of the ground as well when it happened.

    What I believe is the clutch?? (Picture attached) with the red arrow doesn't turn/move.

    It appears the “one way bearing for pull start” doesn't want to turn to the right, should I take it back to the shop and ask for a replacement? I've only owned it for 27 hours.
     

    Attached Files:

  4. Conv3rted

    Conv3rted Member

    Messages:
    17
    Likes Received:
    0
    Joined:
    Jan 12, 2017
    That looks to be your drive gear or spur gear. If that doesnt move then look at brakes possibly locked up or something in the gears. The clutch would be the smaller gear attached to motor. That should spin even if motor is seized i believe. Cant hurt to take it back in. First question is gonna be did you break it in properly so memorize the procedure and assure them you did. If not they won't give you anything for replacement...
     
  5. Plkih

    Plkih New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Jan 15, 2017
    I'll just take it back and explain it to them, I followed all of their instructions and in the manual so they can't say I did anything wrong.

    Thanks for your help! :)
     
  6. Plkih

    Plkih New Member

    Messages:
    4
    Likes Received:
    0
    Joined:
    Jan 15, 2017

    Took it back to the shop today, they took the engine apart and the bearing had exploded! It was in loads of pieces, they're not sure why it happened, but they're fitting a new engine Free of charge.

    Thanks for your help anyway! :)
     
    • Winner Winner x 2
Verification:
Draft saved Draft deleted

Share This Page