Can anyone help me with a new Savage XS not moving after third run?


New Member
Hi Everyone

I bought a brand new Savage XS last year and have been waiting to use it.
I bought two new 2s lipos and the other day took my Savage for a fun on a field and it was perfect. The afternoon I charged both batteries again (have checked them since and they are full of power and work in one of my other radio controlled cars)

The next day when I plug the batteries in I get no forwards or backwards and the steering is really slow. :(

PS: I didnt bash the car as it was a nice flat field :)

One thing to mention is the car did splash through a puddle on the first run (but it was a small puddle) and the car did not get very wet. But I am very confused why all of a sudden the car that has worked three times with no issue has stopped working.

Any ideas on what I need to do to fix this?
New Hampshire
You mention other RCs, will Savage XS your receiver properly run a servo and speed control from one of those? Will a receiver from another RC properly run your Savage XS servo and speed control?

The Savage XS receiver is in the mostly waterproof box so it's hard to imagine it got wet, but this will at least help you determine which component is faulty. I ran my XS several times in snow this winter, though was careful to blow it dry afterwards with an air compressor. I had no electronics issues except the 25mm ESC fan which eventually stopped functioning and had to be replaced.

Latest posts

Members online

No members online now.